Monday, July 18, 2005

NUnit 2.2 and VS2005 B2: BadImageFormatException

Getting BadImageFormatException errors when trying to use NUnit 2.2 with VS2005 Beta 2? There are several spots with the answer on the web. I found my solution at IdentityCrisis. Edit the nunit-gui.exe.config file and add support for the latest framework. Move it to the top of the list of supported runtimes or it won't fix the issue. <startup>    <supportedRuntime version="v2.0.50215" />    <supportedRuntime version="v1.1.4322" />    <supportedRuntime version="v1.0.3705" />    <requiredRuntime version="v1.0.3705" /> </startup>

1 comment:

Anonymous said...

Thanks:-) Just what I needed...
Got stuck in that hole for some time, and then I ran in to this solution... Have seen it some other places, but nobody said it should stand in the top... You just saved my night!


Subscribe (RSS)

The Leadership Journey